Firefly开源社区

12
发表新贴

AIO-3288C 485问题

18

积分

0

威望

0

贡献

技术小白

积分
18
发表于 2019-8-27 15:19:20     
本帖最后由 Luoxf 于 2019-8-27 15:21 编辑

按照485要求安装了 kermit 并配置了波特率115200 ,连接到PC端  USB转485模块,开发板进入kermit命令模式后 发送echo firefly RS485 test… > /dev/ttyS1   ,PC端串口助手无反应。

kermit配置如下:
set line          /dev/ttyS1   set speed         115200   
set carrier-watch off   
set handshake     none  
set flow-control none   robust   
set file type     bin   
set file name     lit   
set rec pack      1000   
set send pack     1000   
set window        5


回复

使用道具 举报

417

积分

2

威望

4

贡献

技术达人

Rank: 2

积分
417
发表于 2019-8-29 10:29:38     
‘开发板进入kermit命令模式’?
楼主应该是理解错了 WIKI 的教程,http://wiki.t-firefly.com/zh_CN/AIO-3288C/driver_uart.html
PC 端使用串口工具监听串口数据,这里使用了 kermit 工具;
开发板通过命令行 `echo xxx > /dev/ttyS1` 往串口发送数据;
串口工具,http://wiki.t-firefly.com/zh_CN/AIO-3288C/debug.html
回复

使用道具 举报

18

积分

0

威望

0

贡献

技术小白

积分
18
发表于 2019-8-29 11:44:39     
penguin 发表于 2019-8-29 10:29
‘开发板进入kermit命令模式’?
楼主应该是理解错了 WIKI 的教程,http://wiki.t-firefly.com/zh_CN/AIO- ...

朋友,我这个板子自带485  也需要USB转接485模块吗?
回复

使用道具 举报

140

积分

0

威望

0

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
140
发表于 2019-8-29 12:01:13     
Luoxf 发表于 2019-8-29 11:44
朋友,我这个板子自带485  也需要USB转接485模块吗?

肯定要转啊,不转怎么链接PC
回复

使用道具 举报

18

积分

0

威望

0

贡献

技术小白

积分
18
发表于 2019-8-29 12:10:13     
Mr.Lee 发表于 2019-8-29 12:01
肯定要转啊,不转怎么链接PC

PC端有个USB转485模块啊,我是通过开发板自带的485用杜邦线跟我PC端USB转485模块通过AB线连接的。
不对吗?
回复

使用道具 举报

417

积分

2

威望

4

贡献

技术达人

Rank: 2

积分
417
发表于 2019-8-29 13:17:44     
Luoxf 发表于 2019-8-29 12:10
PC端有个USB转485模块啊,我是通过开发板自带的485用杜邦线跟我PC端USB转485模块通过AB线连接的。
不对 ...

按照楼主的说法,设备连接应该没有问题。
如上所说,我对你的操作有些疑惑,能否贴图做些具体说明?
回复

使用道具 举报

18

积分

0

威望

0

贡献

技术小白

积分
18
发表于 2019-8-29 14:13:19     
本帖最后由 Luoxf 于 2019-8-29 14:46 编辑
penguin 发表于 2019-8-29 13:17
按照楼主的说法,设备连接应该没有问题。
如上所说,我对你的操作有些疑惑,能否贴图做些具体说明?

可能我搞反了   我在开发板上用的kermit  PC端用的串口调试助手,但是按照教程,我物理连接好后,开发板直接发送echo firefly RS485 test… > /dev/ttyS1,PC端用的PUTTY软件,PUTTY没有任何反应
回复

使用道具 举报

417

积分

2

威望

4

贡献

技术达人

Rank: 2

积分
417
发表于 2019-8-29 15:29:21     
Luoxf 发表于 2019-8-29 14:13
可能我搞反了   我在开发板上用的kermit  PC端用的串口调试助手,但是按照教程,我物理连接好后,开发板 ...

看下是不是线接反了,波特率设置对吗,默认波特率是 9600
回复

使用道具 举报

18

积分

0

威望

0

贡献

技术小白

积分
18
发表于 2019-8-29 15:54:40     
penguin 发表于 2019-8-29 15:29
看下是不是线接反了,波特率设置对吗,默认波特率是 9600

485  A 就A  B就B 嘛   没错的
回复

使用道具 举报

417

积分

2

威望

4

贡献

技术达人

Rank: 2

积分
417
发表于 2019-8-29 16:19:25     
putty.PNG
echo.png

uart.PNG



你再好好检查一下哪里弄错了
回复

使用道具 举报

返回列表
12
*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表