Firefly开源社区

开发板上安装了ubuntu的系统,然后更新了apt的源为清华的源,安装qtcreator遇到问题

140

积分

0

威望

0

贡献

技术小白

积分
140
发表于 2020-1-2 11:45:38     
如下的命令行信息,更新过apt的源为清华的源,安装过程中遇到问题如下,错误已经标红色,大家帮帮忙
root@firefly:/home/firefly# apt-get install qtcreator
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libegl1 : Depends: libglvnd0 (= 1.0.0-2ubuntu2.2) but 1.0.0-2ubuntu2.3 is to be installed
libgl1-mesa-dev : Depends: mesa-common-dev (= 19.2.1-1ubuntu1~18.04.1) but 18.0.5-0ubuntu0~18.04.1 is to be installed
                   Depends: libglvnd-dev but it is not going to be installed
libgles2 : Depends: libglvnd0 (= 1.0.0-2ubuntu2.2) but 1.0.0-2ubuntu2.3 is to be installed
qtcreator : Depends: qml-module-qtqml-models2 but it is not going to be installed
             Depends: qml-module-qtquick-controls (>= 5.5.0~) but it is not going to be installed
             Depends: qml-module-qtquick2 (>= 5.5.0~) but it is not going to be installed
             Depends: qtcreator-data (= 4.5.2-3ubuntu2) but it is not going to be installed
             Depends: libbotan-2-4 but it is not going to be installed
             Depends: libqbscore1.10 (>= 1.10.0) but it is not going to be installed
             Depends: libqbsqtprofilesetup1.10 (>= 1.2.1) but it is not going to be installed
             Depends: libqt5designer5 (>= 5.6.2~) but it is not going to be installed
             Depends: libqt5designercomponents5 (>= 5.6.2~) but it is not going to be installed
             Depends: libqt5help5 (>= 5.6.2~) but it is not going to be installed
             Depends: libqt5quickwidgets5 (>= 5.9.0~beta) but it is not going to be installed
             Recommends: clang but it is not going to be installed
             Recommends: gdb but it is not going to be installed
             Recommends: qmlscene but it is not going to be installed
             Recommends: qt5-doc but it is not going to be installed
             Recommends: qt5-qmltooling-plugins but it is not going to be installed
             Recommends: qtcreator-doc but it is not going to be installed
             Recommends: qtdeclarative5-dev-tools but it is not going to be installed
             Recommends: qttools5-dev-tools but it is not going to be installed
             Recommends: qtxmlpatterns5-dev-tools but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@firefly:/home/firefly#

root@firefly:/home/firefly# apt --fix-broken install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libegl1 libgles2 libglvnd-dev mesa-common-dev
The following NEW packages will be installed:
  libglvnd-dev
The following packages will be upgraded:
  libegl1 libgles2 mesa-common-dev
3 upgraded, 1 newly installed, 0 to remove and 404 not upgraded.
66 not fully installed or removed.
Need to get 0 B/708 kB of archives.
After this operation, 796 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 105719 files and directories currently installed.)
Preparing to unpack .../libegl1_1.0.0-2ubuntu2.3_arm64.deb ...
Unpacking libegl1:arm64 (1.0.0-2ubuntu2.3) over (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libegl1_1.0.0-2ubuntu2.3_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libEGL.so.1.0.0', which is also in package rockchip-mali-midgard14 1.6-1
Preparing to unpack .../libgles2_1.0.0-2ubuntu2.3_arm64.deb ...
Unpacking libgles2:arm64 (1.0.0-2ubuntu2.3) over (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles2_1.0.0-2ubuntu2.3_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libGLESv2.so.2.0.0', which is also in package rockchip-mali-midgard14 1.6-1
Preparing to unpack .../mesa-common-dev_19.2.1-1ubuntu1~18.04.1_arm64.deb ...
Unpacking mesa-common-dev:arm64 (19.2.1-1ubuntu1~18.04.1) over (18.0.5-0ubuntu0~18.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/mesa-common-dev_19.2.1-1ubuntu1~18.04.1_arm64.deb (--unpack):
trying to overwrite '/usr/include/KHR/khrplatform.h', which is also in package libmali-rk-dev:arm64 1.6-1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.3_arm64.deb ...
Unpacking libglvnd-dev:arm64 (1.0.0-2ubuntu2.3) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.3_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libEGL.so', which is also in package rockchip-mali-midgard14 1.6-1
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
/var/cache/apt/archives/libegl1_1.0.0-2ubuntu2.3_arm64.deb
/var/cache/apt/archives/libgles2_1.0.0-2ubuntu2.3_arm64.deb
/var/cache/apt/archives/mesa-common-dev_19.2.1-1ubuntu1~18.04.1_arm64.deb
/var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.3_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@firefly:/home/firefly#


回复

使用道具 举报

617

积分

2

威望

4

贡献

技术大神

Rank: 3Rank: 3

积分
617
发表于 2020-1-2 14:36:51     
不要执行apt upgrade 直接apt update 然后apt 安装,这个是因为本地的mali和ubuntu官方的egl gles有冲突apt upgrade自动更新所有包就会报错导致的,这个问题后面的文件系统会解决,你现在使用的不要使用apt upgrade全部更新应该就不会出现这种问题了
回复

使用道具 举报

140

积分

0

威望

0

贡献

技术小白

积分
140
发表于 2020-1-2 17:02:32     
penguin 发表于 2020-1-2 14:36
不要执行apt upgrade 直接apt update 然后apt 安装,这个是因为本地的mali和ubuntu官方的egl gles有冲突apt ...

事实上 我是没有执行 upgrade  仍然有问题,我是用的ubuntu_18.04_arm64_npu_rootfs.img这个官方提供的rootfs做的ubuntu,结果冲突了,怎么解决下,我发现 友善之臂的rk3399文件系统没有这个问题
回复

使用道具 举报

572

积分

1

威望

0

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
572
发表于 2020-1-2 20:23:31     
renfei 发表于 2020-1-2 17:02
事实上 我是没有执行 upgrade  仍然有问题,我是用的ubuntu_18.04_arm64_npu_rootfs.img这个官方提供的ro ...

试试先用libmali-rk-dev 1.7替换libmali-rk-dev 1.6,用libmali-rk-midgard-t86x-r14p0替换rockchip-mali-midgard14,再安装qtcreator看看
回复

使用道具 举报

140

积分

0

威望

0

贡献

技术小白

积分
140
发表于 2020-1-2 21:44:39     
本帖最后由 renfei 于 2020-1-2 22:09 编辑
rany 发表于 2020-1-2 20:23
试试先用libmali-rk-dev 1.7替换libmali-rk-dev 1.6,用libmali-rk-midgard-t86x-r14p0替换rockchip-mali ...

libmali-rk-midgard-t86x-r14p0和 libmali-rk-dev 1.7 可以从哪里获取友善之臂的rk3399文件系统没有这个问题,我从友善的系统里面拷贝了如下图的库,在目前的文件系统里进行了替换,结果不行,错误依旧
QQ1.jpg

回复

使用道具 举报

572

积分

1

威望

0

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
572
发表于 2020-1-4 09:55:53     
renfei 发表于 2020-1-2 21:44
libmali-rk-midgard-t86x-r14p0和 libmali-rk-dev 1.7 可以从哪里获取友善之臂的rk3399文件系统没有这个 ...

首先要确认http://wiki.t-firefly.com/firefly-rk3399-repo源存在,如果不存在添加如下的一行到sources.list中:
  1. deb http://wiki.t-firefly.com/firefly-rk3399-repo bionic main
复制代码

执行如下的命令就行了:
  1. sudo apt remove rockchip-mali-midgard14
  2. sudo apt install libmali-rk-dev libmali-rk-midgard-t86x-r14p0
  3. sudo apt install qtcreator
复制代码
回复

使用道具 举报

140

积分

0

威望

0

贡献

技术小白

积分
140
发表于 2020-1-11 21:33:44     
rany 发表于 2020-1-4 09:55
首先要确认http://wiki.t-firefly.com/firefly-rk3399-repo源存在,如果不存在添加如下的一行到sources.l ...

按照这个方法已经成功安装了qtcreator。非常感谢感谢;但是又出来新的问题,我运行rockx的例程,在firefly提供的带有npu的镜像上正常工作,如下的输出
Starting /home/build-body-Desktop-Debug/body...
QApplication: invalid style override passed, ignoring it.
spec = local:transfer_proxy
D RKNNAPI: ==============================================
D RKNNAPI: RKNN VERSION:
D RKNNAPI: API: 0.9.5 (a949908 build: 2019-05-07 22:20:43)
D RKNNAPI: DRV: 0.9.7 (29b085c build: 2019-06-03 14:26:19)
D RKNNAPI: ==============================================
init rockx module ok
/home/build-body-Desktop-Debug/body exited with code 0


,但是用firefly提供的ubuntu_18.04_arm64_npu_rootfs的img镜像上运行同样的工程 就出错了,直接初始化失败,如下图,我怀疑firefly提供的配合配置是否有那里不正确,或者说版本不匹配(我用的3399pro的编译说明编译的内核:./build.sh aio-3399pro-jd4.mk),如果是版本问题请问,如何核对NPU的驱动版本是哪个版本,怎么修正法。谢谢!
3.jpg
回复

使用道具 举报

8

积分

0

威望

0

贡献

技术小白

积分
8
发表于 2020-4-17 11:12:46     
这个补丁是否可以放在镜像文件,写一个补丁脚本呢?这样,我们小白安装完后运行下补丁脚本就好了,避免重复掉坑,延长开发时间
回复

使用道具 举报

16

积分

0

威望

0

贡献

技术小白

积分
16
发表于 2020-5-29 10:21:32     
rany 发表于 2020-1-4 09:55
首先要确认http://wiki.t-firefly.com/firefly-rk3399-repo源存在,如果不存在添加如下的一行到sources.l ...

你好,
我是在RK3328-PC的固件ROC-RK3328-PC-UBUNTU18.04-GPT-20200303-1705.img下安装
我sudo apt update后,sudo apt install qtcreator都是没有问题,但是安装qt5-default时,就出现了
和楼主一模一样的报错:

正准备解包 .../libegl1_1.0.0-2ubuntu2.3_arm64.deb  ...
正在将 libegl1:arm64 (1.0.0-2ubuntu2.3) 解包到 (1.0.0-2ubuntu2.2) 上 ...
dpkg: 处理归档 /var/cache/apt/archives/libegl1_1.0.0-2ubuntu2.3_arm64.deb (--unpack)时出错:
正试图覆盖 /usr/lib/aarch64-linux-gnu/libEGL.so.1.0.0,它同时被包含于软件包 rockchip-mali-midgard14 1.6-1
正准备解包 .../libgles2_1.0.0-2ubuntu2.3_arm64.deb  ...
正在将 libgles2:arm64 (1.0.0-2ubuntu2.3) 解包到 (1.0.0-2ubuntu2.2) 上 ...
dpkg: 处理归档 /var/cache/apt/archives/libgles2_1.0.0-2ubuntu2.3_arm64.deb (--unpack)时出错:
正试图覆盖 /usr/lib/aarch64-linux-gnu/libGLESv2.so.2.0.0,它同时被包含于软件包 rockchip-mali-midgard14 1.6-1
正准备解包 .../mesa-common-dev_19.2.8-0ubuntu0~18.04.3_arm64.deb  ...
正在将 mesa-common-dev:arm64 (19.2.8-0ubuntu0~18.04.3) 解包到 (18.2.2-0ubuntu1~18.04.2) 上 ...
dpkg: 处理归档 /var/cache/apt/archives/mesa-common-dev_19.2.8-0ubuntu0~18.04.3_arm64.deb (--unpack)时出错:
正试图覆盖 /usr/include/KHR/khrplatform.h,它同时被包含于软件包 libmali-rk-dev:arm64 1.6-1
dpkg-deb: 错误: 粘贴 subprocess was killed by signal (断开的管道)
正准备解包 .../libglvnd-dev_1.0.0-2ubuntu2.3_arm64.deb  ...
正在解包 libglvnd-dev:arm64 (1.0.0-2ubuntu2.3) ...
dpkg: 处理归档 /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.3_arm64.deb (--unpack)时出错:
正试图覆盖 /usr/lib/aarch64-linux-gnu/libEGL.so,它同时被包含于软件包 rockchip-mali-midgard14 1.6-1
由于已经达到 MaxReports 限制,没有写入 apport 报告。

使用sudo dpkg -i --force-overwrite 强制重写后,再sudo apt -f install 虽然安装成功了,但是系统界面起不来

查询无果,我就卸载了sudo apt remove rockchip-mali-midgard14
系统就起来了,但是这样就缺少了OpenGL的库,不知道怎么对应的下载回来?
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表