Firefly开源社区

RK3288 ubuntu16.04能装Qt5.9.5版本吗?

37

积分

0

威望

0

贡献

技术小白

积分
37
发表于 2020-8-21 19:12:48     
本帖最后由 、饭特稀 于 2020-8-24 09:06 编辑

我是一只技术小白,刚进公司。之前在RK3288板子ubuntu16.04系统上用apt-get install(apt-get install qt5-default qtcreator)命令安装的Qt版本默认的是Qt5.5.1版本,现在客户要求安装5.9.5的版本才能把他们的Qt程序跑起来。
我已经尝试的方法:
①、在Qt官网下载qt-everywhere-opensource-src-5.9.5的压缩包然后在上位机用交叉编译的方式,成功编译并安装了,但把生成的库移植到RK3288板子上运行Qt程序时却报如下错误:
qt.qpa.plugin: Could not find the Qt platform plugins "xcb" in ""
qt.qpa.plugin: Could not find the Qt platform plugins "linuxfb" in ""
还有一段错误提示忘了是什么了。根据错误提示在网上寻求解决方法,做了以后还是不奏效。
②直接把qt-everywhere-opensource-src-5.9.5的压缩包扔到板子上去解压编译,但我的板子内存不给力,解压到一半就提示内存不足无法进行下去了。
现在我真的是搞不懂了,也搞不动了,求求各路大神出手相助。
③直接在板子上用apt-get install命令安装指定5.9.5版本,但是不支持安装此版本,可指定安装5.5.1版本

回复

使用道具 举报

490

积分

0

威望

0

贡献

技术达人

Rank: 2

积分
490
发表于 2020-8-22 09:57:19     
建议用最新的 18.04 文件系统,默认支持 /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5.9.5
回复

使用道具 举报

37

积分

0

威望

0

贡献

技术小白

积分
37
发表于 2020-8-22 13:49:20     
时间的蝴蝶 发表于 2020-8-22 09:57
建议用最新的 18.04 文件系统,默认支持 /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5.9.5

问题是现在发客户着急要,我们有还没搭建好18.04的根文件系统
回复

使用道具 举报

37

积分

0

威望

0

贡献

技术小白

积分
37
发表于 2020-8-22 16:00:52     
时间的蝴蝶 发表于 2020-8-22 09:57
建议用最新的 18.04 文件系统,默认支持 /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5.9.5

还有其他比较简单的实现方法吗?
回复

使用道具 举报

139

积分

0

威望

0

贡献

技术小白

积分
139
发表于 2020-9-8 09:45:54     

回帖奖励 +1

这是少编译了显示组件,配置的时候把xcb选进去再编译
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表