Firefly开源社区

12
发表新贴

【Firefly-RK3399 试用体验】安装qt5

201

积分

2

威望

0

贡献

技术达人

Rank: 2

积分
201
发表于 2017-8-23 11:17:38     
1、更新软件源和升级更新软件
  1. sudo apt-get update
  2. sudo apt-get upgrade
复制代码

2、安装qt5
  1. sudo apt-get install qt5-default
  2. sudo apt-get install qtcreator
复制代码

安装完后,在命令行输入qtcreator,会弹出以下界面。




3、配置环境
在option下,选择Build&Run,在Compilers下按add按钮,选择GCC,选择Compilers path:如下图所示。




然后,选择Kits栏,首先要Remove原有的Manual,然后按Add,配置如下图所示。




以上步骤不能弄反,否则无法成功配置。

4、编译运行
新建工程,按左下角的第一个绿色按钮,如果又空白弹窗出现表示配置成功了。





回复

使用道具 举报

286

积分

0

威望

0

贡献

技术达人

Rank: 2

积分
286
发表于 2017-8-29 18:07:55     
请问可以提供sources.list文件吗?
回复

使用道具 举报

286

积分

0

威望

0

贡献

技术达人

Rank: 2

积分
286
发表于 2017-8-29 18:08:44     
请问可以提供sources.list文件吗?
回复

使用道具 举报

28

积分

0

威望

0

贡献

游客

积分
28
发表于 2017-11-6 18:31:49     
I:\Users\Catcher\Desktop\RK3399\rk3399.jpg
出现了这个问题请问怎么办
回复

使用道具 举报

28

积分

0

威望

0

贡献

游客

积分
28
发表于 2017-11-6 18:37:21     

libGL error: unable to load driver: rockchip_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: rockchip
libGL error: unable to load driver: rockchip_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: rockchip
刚才上面那个图片是这个问题
回复

使用道具 举报

19

积分

0

威望

0

贡献

游客

积分
19
发表于 2018-1-30 16:53:47     
请问第三步骤中,我的板子中没有这个arm-linux-guneabihf-gcc这个文件,这个和板子Ubuntu系统有关系?还是需要单独安装?
%AZAX2S(XO%[A[V%}L2M.png
回复

使用道具 举报

10

积分

0

威望

0

贡献

游客

积分
10
发表于 2018-3-14 16:47:51     
命令行打开qtcreator的时候也是遇到了这些问题,请问有解决方案吗?
回复

使用道具 举报

41

积分

0

威望

0

贡献

游客

积分
41
发表于 2018-4-22 22:57:00     
初学者,留个脚印。做记号。
回复

使用道具 举报

28

积分

0

威望

0

贡献

技术小白

积分
28
发表于 2018-6-30 12:06:36     
gwj 发表于 2018-1-30 16:53
请问第三步骤中,我的板子中没有这个arm-linux-guneabihf-gcc这个文件,这个和板子Ubuntu系统有关系?还是 ...

执行一下$ sudo apt-get install gcc-arm-linux-gnueabihf  device-tree-compiler lzop libncurses5-dev  libssl1.0.0命令就行了
回复

使用道具 举报

28

积分

0

威望

0

贡献

技术小白

积分
28
发表于 2018-6-30 12:07:46     
gwj 发表于 2018-1-30 16:53
请问第三步骤中,我的板子中没有这个arm-linux-guneabihf-gcc这个文件,这个和板子Ubuntu系统有关系?还是 ...

执行一下$ sudo apt-get install gcc-arm-linux-gnueabihf  device-tree-compiler lzop libncurses5-dev  libssl1.0.0命令就行了
回复

使用道具 举报

返回列表
12
*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表