Firefly开源社区

求问libgl无法加载rockchip_dri.so怎么解决

6

积分

0

威望

0

贡献

游客

积分
6
发表于 2018-3-13 10:07:28     
用的Firefly-RK3399_xubuntu1604_201711301130 固件,求指导
回复

使用道具 举报

51

积分

0

威望

0

贡献

游客

积分
51
发表于 2018-3-16 17:10:36     
libgl 不支持的,用libegl
回复

使用道具 举报

59

积分

0

威望

0

贡献

游客

积分
59
发表于 2018-4-2 15:59:05     
luxinchun 发表于 2018-3-16 17:10
libgl 不支持的,用libegl

您好, 能具体说明下怎从libgl换成libegl吗
回复

使用道具 举报

14

积分

0

威望

0

贡献

技术小白

积分
14
发表于 2019-7-16 19:58:39     
同求,怎么样能够让libgl换成libgel呀?在RK3399上使用usb摄像头就会报
libGL error: unable to load driver rockchip_dri.so.
这种错误
回复

使用道具 举报

13

积分

0

威望

0

贡献

技术小白

积分
13
发表于 2020-1-22 00:18:01     
由于Xorg使用的Driver modesettings 默认会加载libglx.so(禁用glx会导致某些通过检测glx环境的应用启动失败), libglx.so会搜索系统中的dri实现库。但是rk3399 Xorg 2D加速是直接基于DRM实现, 并未实现dri库,所以启动过程中,libglx.so会报告如下的错误 。
(EE) AIGLX error: dlopen of /usr/lib/aarch64-linux-gnu/dri/rockchip_dri.so failed.
这个对系统运行没有任何影响,不需要处理。

基于同样的道理,某些应用启动过程中,也会报告如下错误,不用处理,对应用的运行不会造成影响。

libGL error: unable to load driver: rockchip_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: rockchip

Firefly之前发布的某些版本的Ubuntu软件,默认关闭了加载libglx.so,在某些情况下,运行某些应用程序会出现下述错误:

GdkGLExt-WARNING **: Window system doesn't support OpenGL.

修正的方法如下:

删除 /etc/X11/xorg.conf.d/20-modesetting.conf 中一下三行配置。

Section "Module"
     Disable     "glx"
EndSection

see the link here: http://wiki.t-firefly.com/zh_CN/ ... ux_development.html
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表