Firefly开源社区

RK3399移植qt

41

积分

0

威望

0

贡献

技术小白

积分
41
发表于 2018-3-21 21:42:48     
我按照论坛里的教程编译了交叉编译用的qt-arm-5.5.1,但是qtcreator出来的文件在arm板子无法运行,板子上好像没有ld-linux-armhf.so.3这个文件,但是有ld-linux-aarch64.so.1,在板子上编译也是动态链接的ld-linux-aarch64.so.1文件,将自带的ld-2.23.so链接成ld-linux-armhf.so.3也不行,请问需要怎么改呀
回复

使用道具 举报

10

积分

0

威望

0

贡献

技术小白

积分
10
发表于 2018-5-18 14:39:38     
你可以用buildroot生成文件系统,里面可以配置qt,需要联网,生成的文件系统可以直接跑qt
回复

使用道具 举报

10

积分

0

威望

0

贡献

技术小白

积分
10
发表于 2018-5-18 14:41:28     
你可以用buildroot制作文件系统,配置.config时可以选择qt一起编译,生成的文件系统可以直接跑qt
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表