Firefly开源社区

编译 Android 7.1出错

8

积分

0

威望

0

贡献

游客

积分
8
发表于 2018-8-9 17:20:40     
本帖最后由 sz_yys63 于 2018-8-9 18:06 编辑

按照ROC-RK3328-CC编译教程,一步一步操作。但是编译报
环境ubuntu18.04
1.安装 JDK 8成功;
2.安装环境包报错,提示非git-core,而是git;提示无lib32readline-gplv2-dev,去掉更新成功;提示无libesd0-dev,去掉更新成功;
3.android的sdk下载成功 mdk5也成功;但更新远程库,提示无origin;从 gitlab 处同步源码成功;
4.使用 Firefly 脚本编译报错
  1. hc@ubuntu:~/proj/roc-rk3328-cc$ ./FFTools/make.sh -k -j8
  2. ~/proj/roc-rk3328-cc/kernel ~/proj/roc-rk3328-cc
  3.   File "/home/hc/proj/roc-rk3328-cc/kernel/scripts/gcc-wrapper.py", line 66
  4.     print "error, forbidden warning:", m.group(2)
  5.                                     ^
  6. <font color="#ff0000">SyntaxError: invalid syntax</font>

  7. *** Error during writing of the configuration.

  8. /home/hc/proj/roc-rk3328-cc/kernel/scripts/kconfig/Makefile:105: recipe for target 'firefly_defconfig' failed
  9. make[1]: *** [firefly_defconfig] Error 1
  10. Makefile:524: recipe for target 'firefly_defconfig' failed
  11. make: *** [firefly_defconfig] Error 2
复制代码

5.不使用脚本编译也报错
  1. No private recovery resources for TARGET_DEVICE roc_rk3328_cc_box
  2. build/core/base_rules.mk:341: warning: overriding commands for target `out/target/product/roc_rk3328_cc_box/system/etc/init/bluetoothtbd.rc'
  3. build/core/base_rules.mk:341: warning: ignoring old commands for target `out/target/product/roc_rk3328_cc_box/system/etc/init/bluetoothtbd.rc'
  4. build/core/Makefile:34: warning: overriding commands for target `out/target/product/roc_rk3328_cc_box/system/xbin/su'
  5. build/core/base_rules.mk:319: warning: ignoring old commands for target `out/target/product/roc_rk3328_cc_box/system/xbin/su'
  6. build/core/Makefile:34: warning: overriding commands for target `out/target/product/roc_rk3328_cc_box/system/lib/libmpp.so'
  7. build/core/base_rules.mk:319: warning: ignoring old commands for target `out/target/product/roc_rk3328_cc_box/system/lib/libmpp.so'
  8. build/core/Makefile:34: warning: overriding commands for target `out/target/product/roc_rk3328_cc_box/system/lib/libvpu.so'
  9. build/core/base_rules.mk:319: warning: ignoring old commands for target `out/target/product/roc_rk3328_cc_box/system/lib/libvpu.so'
  10. Starting build with ninja
  11. ninja: Entering directory `.'
  12. <font color="#ff0000">ninja: error: unknown target 'firefly_defconfig'</font>
  13. build/core/ninja.mk:148: recipe for target 'ninja_wrapper' failed
  14. make: *** [ninja_wrapper] Error 1
  15. hc@ubuntu:~/proj/roc-rk3328-cc$
复制代码




回复

使用道具 举报

8

积分

0

威望

0

贡献

游客

积分
8
发表于 2018-8-10 09:14:19     
自己顶,没有人遇到吗?
回复

使用道具 举报

2842

积分

12

威望

22

贡献

注册会员

Rank: 8Rank: 8

积分
2842
发表于 2018-8-10 17:15:10     
sz_yys63 发表于 2018-8-10 09:14
自己顶,没有人遇到吗?

应该是python版本不对
我是Python 2.7.6,你可以参考一下
回复

使用道具 举报

40

积分

0

威望

0

贡献

技术小白

积分
40
发表于 2019-5-16 10:02:54     
leung先森 发表于 2018-8-10 17:15
应该是python版本不对
我是Python 2.7.6,你可以参考一下

楼主解决了吗?我也遇到这样的问题
回复

使用道具 举报

2842

积分

12

威望

22

贡献

注册会员

Rank: 8Rank: 8

积分
2842
发表于 2019-5-16 16:31:19     
lilinrong 发表于 2019-5-16 10:02
楼主解决了吗?我也遇到这样的问题

换个Python试试把
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表