Firefly开源社区

安卓源码编译错误,请求大神帮忙解决

27

积分

0

威望

0

贡献

技术小白

积分
27
发表于 2019-6-17 14:53:50     
按官方教程编译后出现此错误,是什么情况?

系统是ubuntu 14.04 LTS

终端信息:
proj/firefly-rk3288-lollipop/kernel$ make firefly_defconfig
  HOSTCC  scripts/basic/fixdep
/bin/sh: 1: scripts/basic/fixdep: Permission denied
make[1]: *** [scripts/basic/fixdep] 错误 126
make: *** [scripts_basic] 错误 2
回复

使用道具 举报

1844

积分

16

威望

18

贡献

中级创客

Rank: 4

积分
1844
QQ
发表于 2019-6-18 14:57:11     
你应该按照wiki把环境搭配好先
http://wiki.t-firefly.com/zh_CN/ ... ompile_android.html
回复

使用道具 举报

27

积分

0

威望

0

贡献

技术小白

积分
27
发表于 2019-6-19 10:54:18     
本帖最后由 Guohui0416 于 2019-6-26 15:32 编辑

问题已经解决,确定 是gcc的问题;终端查询gcc -v显示没有安装,事实已经安装;
此时必须删除gcc,再安装就能解决
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表