Firefly开源社区

相机isp调试

49

积分

0

威望

0

贡献

技术小白

积分
49
发表于 2019-6-25 14:08:08     
官方给的库有问题吗
pen /usr/lib/libcam_ia.so failed, error /usr/lib/libcam_ia.so: undefined symbol: __cxa_pure_virtual
Load libcam_engine_cifisp.so successed
dlsym rkisp_start success
device manager start, capture dev fd: 4
rkisp_demo: symbol lookup error: /usr/lib/libcam_engine_cifisp.so: undefined symbol: pthread_mutexattr_init


捕获.PNG
捕获2.PNG
回复

使用道具 举报

397

积分

2

威望

4

贡献

技术达人

Rank: 2

积分
397
发表于 2019-6-25 18:07:32     
什么固件,16.04还是18.04  用18.04试一下
回复

使用道具 举报

49

积分

0

威望

0

贡献

技术小白

积分
49
发表于 2019-6-26 17:06:27     
penguin 发表于 2019-6-25 18:07
什么固件,16.04还是18.04  用18.04试一下

用的是18.04,目前官方给的动态库报错,不开源,感觉没法搞了。
回复

使用道具 举报

15

积分

0

威望

0

贡献

技术小白

积分
15
发表于 2019-7-29 10:12:16     
你好,我也遇到了同样的问题,以下是我的详细报错信息,请问有解决办法了吗?

===============================================================================

pi@nanopineo4:/usr/lib$ sudo gst-camera.sh
[sudo] password for pi:
/usr/bin/gst-camera.sh: line 196:  2442 Terminated              gst-launch-1.0 rkisp device=/dev/video1 io-mode=4 ! video/x-raw,format=NV12,width=1280,height=720,framerate=30/1 ! kmssink
====================================================
=== GStreamer 1.1 command:
=== gst-launch-1.0 rkisp device=/dev/video1 io-mode=4 ! video/x-raw,format=NV12,width=1280,height=720,framerate=30/1 ! kmssink
====================================================
XCAM ERROR device_manager.cpp:88: open /usr/lib/libcam_ia.so failed
XCAM ERROR device_manager.cpp:94: open /usr/lib/libcam_engine_cifisp.so failed
Setting pipeline to PAUSED ...
XCAM WARNING v4l2_device.cpp:171: set capture mode(0x00004000) failed but continue
XCAM WARNING v4l2_device.cpp:171: set capture mode(0x00004000) failed but continue
XCAM INFO x3a_image_process_center.cpp:48: Add processor(IspImageProcessor) into image processor center
Pipeline is live and does not need PREROLL ...
XCAM INFO v4l2_device.cpp:322: device(/dev/video1) set format(w:1280, h:720, pixelformat:NV12, bytesperline:1280)
XCAM WARNING rkisp_device.cpp:48: atomisp device(/dev/video1) get framerate failed
XCAM ERROR rkisp_device.cpp:72: atomisp device(/dev/video1) try subdev format failed
XCAM WARNING v4l2_device.cpp:233: device(/dev/video1) pre_set_format failed
XCAM ERROR v4l2_device.cpp:244: Fail to set format: Invalid argument
CAMHALError:  ERR(getSensorModeData): RK_VIDIOC_SENSOR_MODE_DATA failed, err: Inappropriate ioctl for device

Setting pipeline to PLAYING ...
CAMHALInfo:   init:tuningFile /etc/cam_iq.xml
CAMHALInfo:   load tunning file failed..
CAMHALError:  init: initstatic failed
CAMHALInfo:   rkisp_start: interface isp dev started
XCAM INFO v4l2_device.cpp:473: request buffers in device(/dev/video1)
XCAM INFO v4l2_device.cpp:476: device(/dev/video1) starts failed on VIDIOC_REQBUFS
XCAM ERROR v4l2_device.cpp:408: device(/dev/video1) start failed
XCAM ERROR device_manager.cpp:227: capture device start failed
XCAM INFO xcam_analyzer.cpp:226: Analyzer(X3aAnalyzerSimple) stopped.
XCAM INFO xcam_analyzer.cpp:178: Analyzer(X3aAnalyzerSimple) deinited.
CAMHALInfo:   rkisp_stop: rkisp interface ready to deinit
XCAM INFO v4l2_device.cpp:457: device(/dev/video1) stopped
New clock: GstSystemClock
ERROR: from element /GstPipeline:pipeline0/GstXCamSrc:xcamsrc0: Internal data stream error.
Additional debug info:
gstbasesrc.c(3055): gst_base_src_loop (): /GstPipeline:pipeline0/GstXCamSrc:xcamsrc0:
streaming stopped, reason not-negotiated (-4)
Execution ended after 0:00:00.000594066
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
XCAM INFO xcam_analyzer.cpp:226: Analyzer(X3aAnalyzerSimple) stopped.
XCAM INFO xcam_analyzer.cpp:178: Analyzer(X3aAnalyzerSimple) deinited.
CAMHALInfo:   rkisp_stop: rkisp interface ready to deinit
/usr/bin/gst-camera.sh: line 196:  3126 Bus error               gst-launch-1.0 rkisp device=/dev/video1 io-mode=4 ! video/x-raw,format=NV12,width=1280,height=720,framerate=30/1 ! kmssink

===============================================================================
回复

使用道具 举报

47

积分

0

威望

0

贡献

技术小白

积分
47
发表于 2019-7-29 11:21:41     
我是/usr/local/bin下的双摄测试都无法运行
回复

使用道具 举报

27

积分

0

威望

0

贡献

技术小白

积分
27
发表于 2019-7-29 15:03:41     
这个问题是你的交叉编译工具问题,你看下内核使用的哪个版本交叉编译工具,SO库交叉编译工具是哪个版本,如果不一样肯定无法调用
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表