Firefly开源社区

12
发表新贴

RK3288无法升级loader

65

积分

0

威望

0

贡献

技术小白

积分
65
发表于 2015-4-13 11:32:41     
本帖最后由 x-forever 于 2015-4-13 11:34 编辑

原来因为一些其它兴趣需要从sd card启动,所以升级成v2.17的u-boot

现在需要该换回v2.15版本重新进入原来的双系统,升级的时候提示IDB获取失败。
Linux 下执行如下(Ubuntu 12.04, Linux_Upgrade_Tool_v1.2):

ygu@fs-ygu:/firefly-img/rk3288/create-sdcard$ sudo upgrade_tool ul RK3288Loader_uboot_V2.15.01.bin
Loading loader...
Support Type:RK320A        Loader ver:2.15        Loader Time:2014-08-27 16:57:31
Prepare IDB Fail

Windows下执行如下 (Win7, AndroidTool_Release_v2.3):
1. 可以检测到设备
loader-1.png



2. 设置loader为v2.15版本后电击“执行”尝试更新loader失败
loader-2.png


3. 能够正常读取flash信息
loader-3.png


4. 在“高级功能”一项设置了boot,选择v2.15的loader,点击下载,提示设备类型不匹配
loader-4.png



我原来是在Linux下这样升级v2.17loader的:
  • Download the update tool for Linux:wget http://www.t-firefly.com/downloa ... de_Tool_v1.2.tar.gz
  • Extract the update tool and make it available to the list of programs that the user can execute:
    tar xf Linux_Upgrade_Tool_v1.2.tar.gz
    cd Linux_Upgrade_Tool_v1.2
    sudo mv upgrade_tool /usr/local/bin
    sudo chown root:root /usr/local/bin/upgrade_tool
  • Power on Firefly-RK3288.
  • Use micro USB OTG cable to connect Firefly-RK3288 to the personal computer.
  • Press and hold RECOVERY hardware button. After that shortly press RESET hardware button and after two seconds release RECOVERY.
  • Flash the new bootloader:sudo upgrade_tool ul RK3288Loader_uboot_V2.17.02.bin

    我对Rockchip平台的烧写不熟悉,恳请论坛的各位前辈指点下,在下十分感激!




回复

使用道具 举报

2821

积分

56

威望

46

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
2821

优秀版主论坛元老

发表于 2015-4-13 18:00:13     
AndroidTool_Release_v2.33有试过吗?
回复

使用道具 举报

65

积分

0

威望

0

贡献

技术小白

积分
65
发表于 2015-4-13 23:48:12     
没呢~~
回复

使用道具 举报

65

积分

0

威望

0

贡献

技术小白

积分
65
发表于 2015-4-13 23:49:50     
找个时间试下2.33版本的吧,谢谢啦

有哪位前辈遇到过类似问题的也请指点下啊~
回复

使用道具 举报

23

积分

0

威望

0

贡献

技术小白

积分
23
发表于 2016-4-12 14:36:40     
x-forever 发表于 2015-4-13 23:49
找个时间试下2.33版本的吧,谢谢啦

有哪位前辈遇到过类似问题的也请指点下啊~

您好,请问这个问题解决了吗?
回复

使用道具 举报

3167

积分

17

威望

18

贡献

高级创客

Rank: 6Rank: 6

积分
3167
QQ
发表于 2016-4-13 14:44:51     
luxiaoaidi 发表于 2016-4-12 14:36
您好,请问这个问题解决了吗?

可参看如下帖子
http://developer.t-firefly.com/thread-5902-1-1.html
回复

使用道具 举报

65

积分

0

威望

0

贡献

技术小白

积分
65
发表于 2016-5-27 17:36:17     
很久不曾上线,最近又重新拿起firefly玩一玩,参考jpchen的帖子已经可以更新了,谢谢jpchen!
回复

使用道具 举报

14

积分

0

威望

0

贡献

游客

积分
14
发表于 2016-6-3 22:48:31     
楼主解决了吗,我也遇到一模一样的问题,头都大了。
回复

使用道具 举报

57

积分

0

威望

0

贡献

技术小白

积分
57
发表于 2016-7-25 11:55:24     
我用的是V2.35的,还是提示 “设备类型不匹配,停止运行”
回复

使用道具 举报

65

积分

0

威望

0

贡献

技术小白

积分
65
发表于 2019-6-13 11:54:06     
我最近用v2.58的工具,升级Android 5.1的Update固件,提示说下载固件失败,继续求救啊~~
download-firmware-fail.png

回复

使用道具 举报

返回列表
12
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表