Firefly开源社区

12
发表新贴

[Linux] 3399pro 已经支持RKNN Toolkit 1.7.1版本了 (Linux)

826

积分

0

威望

6

贡献

技术大神

Rank: 8Rank: 8

积分
826
发表于 2022-5-16 15:24:17     
问题描述及复现步骤:
安装之前建议先看前言哦!
AIO-3399Pro-JD4 和 AIO-3399ProC 一些推理性能的处理方法不同,不看前言容易吃亏{:4_91:}
1652685247(1).jpg

板子上安装建议安装 RKNN Toolkit Lite


RKNN Toolkit Lite 是 RKNN Toolkit 的精简版本,为用户提供在 PC、RK3399Pro、RK1808、RK1806、V1109、RV1126 上进行模型推理的开发套件。用户通过该 SDK 提供的 Python 接口可以方便、快速地完成 AI 应用的开发和部署。相比 RKNN Toolkit 繁杂且费时的安装过程, RKNN Toolkit Lite 安装过程只需十分钟不到。

跳转链接:
RK3399Pro NPU 手册

当然有什么3399pro Linux 的问题也可以帖子下留言,最后就是帖子下留你发帖子的链接我可以及时回复

RK3399Pro NPU Manual.zip

206 Bytes, 下载次数: 11, 下载积分: 灯泡 -1 , 经验 -1

回复

使用道具 举报

826

积分

0

威望

6

贡献

技术大神

Rank: 8Rank: 8

积分
826
发表于 2022-5-18 11:47:31     
注意:想要运行模型除了需要安装 RKNN Toolkit 之外还需安装,NPU驱动。

运行Ubuntu 的板子上命令行输入:
  1. sudo apt update
  2. sudo apt install firefly-3399pronpu-driver
  3. # reboot
  4. sudo reboot
复制代码


image.png
回复

使用道具 举报

9

积分

0

威望

0

贡献

吃瓜的群众

积分
9
发表于 2022-7-6 08:57:54     
大神你好,可以请问下,请问可不可以在pc上搭建SDK库进行开发,大致的环境搭建流程是怎么样的,盼回复。
回复

使用道具 举报

11

积分

0

威望

0

贡献

技术小白

积分
11
发表于 2022-7-7 10:58:39     
谢谢,我想问下:
      1.3588支持RKNN Toolkit Lite这套吗?因为我在3588的文档中没有看到,上面的开发套件中也没有提及3588,于是来问下。
      2.是不是意味着,支持RKNN Toolkit Lite的开发套件,可以直接使用python进行开发?(python我比较了解,C++的不太懂)
      再次感谢,期待回复
回复

使用道具 举报

826

积分

0

威望

6

贡献

技术大神

Rank: 8Rank: 8

积分
826
发表于 2022-7-7 14:53:17     
wx__VHZT5J 发表于 2022-7-6 08:57
大神你好,可以请问下,请问可不可以在pc上搭建SDK库进行开发,大致的环境搭建流程是怎么样的,盼回复。

具体开发你可以看rknn-toolkit下的doc文件,这里面是原始资料比较全

https://github.com/rockchip-linux/rknn-toolkit
回复

使用道具 举报

826

积分

0

威望

6

贡献

技术大神

Rank: 8Rank: 8

积分
826
发表于 2022-7-7 14:55:49     
Q.IAN 发表于 2022-7-7 10:58
谢谢,我想问下:
      1.3588支持RKNN Toolkit Lite这套吗?因为我在3588的文档中没有看到,上面的开发 ...

1. 差不多,但是rk3588使用的是rknn-toolkit2
https://github.com/rockchip-linux/rknn-toolkit2

2. 可以用Python开发
回复

使用道具 举报

11

积分

0

威望

0

贡献

技术小白

积分
11
发表于 2022-7-12 13:48:49     
谢谢,收到了官方的邮件回复,内容如下:
1.rk3588/rk3588s支持的是RKNN Toolkit2 Lite的版本
2.RKNN Toolkit2 Lite 工具使用 python 简化模型的部署和运行,RKNN Toolkit2 Lite具体可以参考一下文档Rockchip_User_Guide_RKNN_Toolkit_Lite2_V1.*_CN.pdf说明,另外RKNN Toolkit2 Lite需要部署在运行linux系统的板端,一般是跑Debian系统
回复

使用道具 举报

27

积分

0

威望

0

贡献

技术小白

积分
27
发表于 2022-8-30 13:53:38     
本帖最后由 星魂 于 2022-8-30 13:55 编辑

rk3399pro 驱动1.7.1版本,对应的rknn-api_1.7.1库在哪里下载呢
回复

使用道具 举报

826

积分

0

威望

6

贡献

技术大神

Rank: 8Rank: 8

积分
826
发表于 2022-8-30 14:20:05     
星魂 发表于 2022-8-30 13:53
rk3399pro 驱动1.7.1版本,对应的rknn-api_1.7.1库在哪里下载呢

这个:
https://gitlab.com/firefly-linux/external/rknpu
回复

使用道具 举报

27

积分

0

威望

0

贡献

技术小白

积分
27
发表于 2022-8-30 15:24:34     
895816513 发表于 2022-8-30 14:20
这个:
https://gitlab.com/firefly-linux/external/rknpu

你发的链接中适合rk3399pro的只有1.6.1版本的rknn-api
回复

使用道具 举报

返回列表
12
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Copyright © 2014-2022 中山市天启智能科技有限公司 粤ICP备14022046号
快速回复 返回顶部 返回列表