Firefly开源社区

[应用开发] 请问aio-3588sjd4-BE45-A1-buildroot 的sdk_v1.0.2a版本的rockit接口是否已调通?

140

积分

0

威望

0

贡献

技术小白

积分
140
发表于 2022-10-20 10:09:05     
  • 固件类型: 自行编译的固件
  • SDK包名称: rk3588_repo_sdk_v1.0.2a.7z
  • SDK更新到哪个COMMIT: 0000-00-00 00:00:00
  • SDK修改内容: 未改动,编译固件
  • Log日志: rk_mpi例程报错.zip
问题描述及复现步骤:
版本号:
root@RK3588:/# cat /proc/version
Linux version 5.10.110 (ubuntu@ubuntu) (kernel commit id: 44dbce6d6463) (sdk version: rk3588_linux_release_20221012_v1.0.2a) (aarch64-none-linux-gnu-gcc (GNU Toolchain for the A-profile Architecture 10.3-2021.07 (arm-10.29)) 10.3.1 20210621, GNU ld (GNU Toolchain for the A-profile Architecture 10.3-2021.07 (arm-10.29)) 2.36.1.20210621) #1 SMP Thu Oct 13 20:19:05 CST 2022
硬件环境:
aio-3588sjd4-BE45-A1-buildroot
问题描述:
sdk version: rk3588_linux_release_20221012_v1.0.2a已添加了rockit模块,并且默认将rk_mpi_xxx_xxx测试工具编译进系统,运行例程"rk_mpi_vi_test"报“段错误”,发现源码中有大量356X有关的宏定义,rockit接口是否已适配rk3588s平台?

rk_mpi例程报错.zip

652 Bytes, 下载次数: 0, 下载积分: 灯泡 -1 , 经验 -1

回复

使用道具 举报

1万

积分

7

威望

0

贡献

技术大神

Rank: 8Rank: 8

积分
11008

突出贡献

发表于 2022-10-20 11:38:40     
要将 rockit/mpi/sdk/lib64/libgraphic_lsf.so 库文件拷贝到 /usr/lib/ 路径下,替换掉原来的libgraphic_lsf.so文件。然后再次执行demo就没有出现段错误了
回复

使用道具 举报

1万

积分

7

威望

0

贡献

技术大神

Rank: 8Rank: 8

积分
11008

突出贡献

发表于 2022-10-20 11:39:27     
rockit接口还未完全调通。需要等后续更新。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Copyright © 2014-2022 中山市天启智能科技有限公司 粤ICP备14022046号
快速回复 返回顶部 返回列表