Firefly开源社区

FirePrime版上BLE功能無法work

24

积分

0

威望

0

贡献

游客

积分
24
发表于 2016-4-15 15:36:15     
fireprime的版子(version: FirePrime_Android5.1_201603030926), 我遇到Bluetooth lowenergy功能上的問題,
我用google play上的BLE裝置連線的APK, 始終無法連上BLE的裝置,
但使用在一樣是android 5.1.1的手機卻是可以正常使用的,
另外也參考了其它版友的範例, 一樣不行....
FirePrime 板上 BLE 做Peripheral模式样例
Error log: E/BluetoothAdapter( 2531): bluetooth le advertising not supported


Fireprime是有支持藍芽4.0, 應該是有支持BLE才對,
請問是要修改甚麼設定才能讓BLE功能正常?


回复

使用道具 举报

2885

积分

56

威望

46

贡献

高级创客

Rank: 6Rank: 6

积分
2885

优秀版主论坛元老

发表于 2016-4-18 14:57:30     
frameworks/base/core/res/res/values/config.xml:
修改config_bluetooth_le_peripheral_mode_supported为true试试
回复

使用道具 举报

24

积分

0

威望

0

贡献

游客

积分
24
发表于 2016-4-20 11:22:21     
萬分的感謝zhansb

修改config_bluetooth_le_peripheral_mode_supported為true後, peripheral mode成功連上手機

但還有個問題是central mode一樣無法使用

是否還有其它的設定需要修改??
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表