Firefly开源社区

12
发表新贴

android4.4如何修改默认休眠时间?

54

积分

0

威望

0

贡献

技术小白

积分
54
发表于 2015-3-21 15:13:31     
我网上查过很多资料,加了个"从不“选项,但是默认休眠时间怎么改也改不成“从不”
回复

使用道具 举报

714

积分

68

威望

68

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
714
QQ
发表于 2015-3-23 09:43:11     
按照之前的经验修改:
/frameworks/base/packages/SettingsProvider/res/values/defaults.xml 中的 def_screen_off_timeout 为-1即可。
修改后模块编译SettingsProvider,adb push进机器,然后恢复出场试下?
回复

使用道具 举报

265

积分

5

威望

6

贡献

实习版主

Rank: 7Rank: 7Rank: 7

积分
265

活跃会员热心会员突出贡献

发表于 2015-3-23 09:52:46     
百度很多类似的修改
回复

使用道具 举报

54

积分

0

威望

0

贡献

技术小白

积分
54
发表于 2015-3-23 19:33:07     
风之空响 发表于 2015-3-23 09:43
按照之前的经验修改:
/frameworks/base/packages/SettingsProvider/res/values/defaults.xml 中的 def_s ...

版主,亲测,无效。
另外,也试过修改device/rockchip/rk3288/system.prop的ro.rk.screenoff_time为-1,也无效
回复

使用道具 举报

54

积分

0

威望

0

贡献

技术小白

积分
54
发表于 2015-3-23 19:34:24     
carlinluo 发表于 2015-3-23 09:52
百度很多类似的修改

我在这里提的问题,都是之前查过,没有解决的。
回复

使用道具 举报

714

积分

68

威望

68

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
714
QQ
发表于 2015-3-24 10:07:59     
yaolunlun 发表于 2015-3-23 19:33
版主,亲测,无效。
另外,也试过修改device/rockchip/rk3288/system.prop的ro.rk.screenoff_time为-1 ...

你的是pad版的固件?
回复

使用道具 举报

54

积分

0

威望

0

贡献

技术小白

积分
54
发表于 2015-3-24 14:12:37     
是pad版的
回复

使用道具 举报

714

积分

68

威望

68

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
714
QQ
发表于 2015-3-24 15:00:30     

ok,我看下告诉你
回复

使用道具 举报

54

积分

0

威望

0

贡献

技术小白

积分
54
发表于 2015-3-25 16:21:49     
版主,这个问题解决了吗?:'(
回复

使用道具 举报

714

积分

68

威望

68

贡献

社区版主

Rank: 7Rank: 7Rank: 7

积分
714
QQ
发表于 2015-3-26 10:18:11     
yaolunlun 发表于 2015-3-25 16:21
版主,这个问题解决了吗?

0001-Android-Settings-Display-never-sleep.patch.tar (10 KB, 下载次数: 128)
回复

使用道具 举报

返回列表
12
*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表