Firefly开源社区

在开发板上编译系统时发现缺了部分工具

6

积分

0

威望

0

贡献

技术小白

积分
6
发表于 2020-7-2 17:00:32     
最近开始玩开发板,打算编译一个Ubuntu系统试试。
但自己的机器是win10,网上搜索到一些信息说是不要用虚拟机编译,所以在开发板上做。
按照wiki一步一步制作Ubuntu根文件系统,还算顺畅。
准备Buildroot环境时,问题来了。
需要安装的若干工具中有好几个找不到,日志信息如下:

Package gcc-aarch64-linux-gnu is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package gcc-arm-linux-gnueabihf is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gcc-arm-linux-gnueabihf' has no installation candidate
E: Package 'gcc-aarch64-linux-gnu' has no installation candidate
E: Unable to locate package libc6:i386
E: Unable to locate package lib32stdc++6
E: Couldn't find any package by regex 'lib32stdc++6'

请问是开发板上就缺少相关工具无法编译,还是说需要用别的工具替换?
问题有点菜,还请路过的大侠指点一二。
回复

使用道具 举报

664

积分

2

威望

4

贡献

技术大神

Rank: 3Rank: 3

积分
664
发表于 2020-7-3 14:18:13     
sdk编译都是在pc上验证过的的,虚拟机也是可以的,最好在pc上编译,wiki上的环境安装也是按照pc上安装的,不建议在开发板上编译系统。
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表