Firefly开源社区

经验分享:Arduino IDE增加Fireduino支持及编译不成功问题的解决方法

399

积分

0

威望

0

贡献

注册会员

Rank: 8Rank: 8

积分
399
QQ
发表于 2016-11-14 14:51:29     
本帖最后由 安安 于 2016-11-14 14:51 编辑

问题一:版本管理器更新出现CRC doesn't match. File is corrupte。错误情况如下图:
CRCMatchErr.png
出错原因:
    此问题一般出现于使用了官方开发板管理器进行更新SDK时,packages校验的时候出错了。
解决方法:
    在更新之前,我们先打开开发板管理器更新包的存放目录,默认目录路径为C:\Users\XXX\AppData\Local\Arduino15\staging\packages(XXX表示当前用户名,笔者用户名为my),删除如图以下这两个文件格式如“fireduino_sdk-x.x.x.tar.gz”的文件(更新包),然后重新升级一遍SDK。
Packages Path.png


问题二:编译过程中,出现error compiling for board fireduino的解决方法。
Fireduino 平台未知错误.png
出错原因:
    平台支持包访问错误。
解决方法:
    根据Arduino IDE安装的方法不同,从以下路径找到平台支持包。
1.Fireduino 官方下载解压版:arduino-1.6.8\portable\packages\Firefly\hardware\arm(“arduino-1.6.8”为解压后的文件夹)
2.Arduino 官方IDE安装版:C:\Users\XXX\AppData\Local\Arduino15\packages\Firefly\hardware\arm
             删除与开发板管理器中SDK 版本不对应的文件夹,如图,目前最新版本为1.3.0,应该仅保留如下文件夹:
文件夹1.3.0冲突错误.png


   

没个性,不签名!
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表