Firefly开源社区

UART0能收不能发

411

积分

0

威望

0

贡献

技术达人

Rank: 2

积分
411
发表于 2018-12-12 17:35:21     
因为UART0是和蓝牙复用的,自己做的底板用了UART0,我就关闭了蓝牙,打开UART0口
发现能正常接收但不能正常发送,这个真的很不解,是还需要有地方配置么?

&uart0 {
        pinctrl-names = "default";
        pinctrl-0 = <&uart0_xfer>;
        status = "okay";
};
哪位大神能指点一下?
回复

使用道具 举报

13

积分

0

威望

0

贡献

技术小白

积分
13
发表于 2018-12-26 15:15:48     
遇到同样的问题,请问解决了吗
回复

使用道具 举报

118

积分

0

威望

0

贡献

技术小白

积分
118
发表于 2018-12-26 16:52:55     
亲测没问题,直接disabled蓝牙就ok
回复

使用道具 举报

411

积分

0

威望

0

贡献

技术达人

Rank: 2

积分
411
发表于 2019-2-20 16:22:12     
wx_Mr.Lee_g8Ao8 发表于 2018-12-26 16:52
亲测没问题,直接disabled蓝牙就ok

dts里面关闭了啊,还有其他地方需要配置disable么?       
wireless-bluetooth {
                compatible = "bluetooth-platdata";
                clocks = <&rk808 1>;
                clock-names = "ext_clock";
                //wifi-bt-power-toggle;
                uart_rts_gpios = <&gpio2 19 GPIO_ACTIVE_LOW>; /* GPIO2_C3 */
                pinctrl-names = "default", "rts_gpio";
                pinctrl-0 = <&uart0_rts>;
                pinctrl-1 = <&uart0_gpios>;
                //BT,power_gpio  = <&gpio3 19 GPIO_ACTIVE_HIGH>; /* GPIOx_xx */
                BT,reset_gpio    = <&gpio0 9 GPIO_ACTIVE_HIGH>; /* GPIO0_B1 */
                BT,wake_gpio     = <&gpio2 26 GPIO_ACTIVE_HIGH>; /* GPIO2_D2 */
                BT,wake_host_irq = <&gpio0 4 GPIO_ACTIVE_HIGH>; /* GPIO0_A4 */
                status = "disabled";
        };
回复

使用道具 举报

432

积分

0

威望

0

贡献

技术达人

Rank: 2

积分
432
发表于 2019-2-26 17:20:47     
看下发送端的GPIO口有没被占用
回复

使用道具 举报

*滑块验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

友情链接 : 爱板网 电子发烧友论坛 云汉电子社区 粤ICP备14022046号-2
快速回复 返回顶部 返回列表